Tag Archives: hdd

Fix Windows Backup Error: 0x8078002A on 2.5TB and 3TB WD Drives

“One of the backup files could not be created. Detailed Error: The request could not be performed because of an I/O device error”

Hard DriveLook familiar? Have a Western Digital hard drive that you are trying to back up to?

I would like to quickly mention a solution that I found for larger (2.5TB or more) Western Digital hard drives that use “advanced format” 4KB physical sector sizes. Many users complain about an issue with Windows 7 Backup and Windows Server backup which spits out the useless Error 0x8078002A.

This worked for my 3TB WD Elements drive. Out of the box this drive did not work with Windows backup at all. WD support actually came through for me on this issue and pointed me to the following solution:

http://wdc.custhelp.com/app/answers/detail/a_id/6618/session/L3RpbWUvMTMxMzUzNzc5My9zaWQvT1hrMSpJQms%3D

Basically it consists of formatting the drive with their external drive formatting utility in “Factory Default” mode rather than XP-Compatible mode which (ironically) is how the drive ships. After performing the format, the drive works fine with Windows backup in both Windows 7 and Windows Server, but is incompatible with Windows XP. In my case, this is an acceptable compromise.

This is how the drive appeared out of the box:

C:Windowssystem32>fsutil fsinfo ntfsinfo H:
Bytes Per Sector  :               4096
Bytes Per Physical Sector :       <Not Supported>
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 4096

This is how the drive appeared after the “Factory Default” format:

C:Windowssystem32>fsutil fsinfo ntfsinfo H:
Bytes Per Sector  :               512
Bytes Per Physical Sector :       <Not Supported>
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 1024

Finally, I should point out that this utility will probably not work for drives from manufacturers other than Western Digital as it scans for WD drives specifically on launch and is likely working directly with their drives’ firmware. That said, I do believe this should cover all WD drives 2.5TB and larger to correct this issue.